Moodle 3.2 or later requires at least PHP 5.6.5 (currently using version 5.5.34-1+deb.sury.org~precise+1).
Please upgrade your server software or install older Moodle version.